Jump to content
MattW

CTM 300 - which cab? Barefaced?

Recommended Posts

2 minutes ago, stewblack said:

Hmm. I think I've heard this story here before. PMT dodgy CTM. Not good. 

Agreed, it would appear they are repeatedly sending the same dodgy amp out.

  • Thanks 1

Share this post


Link to post
Share on other sites
9 hours ago, MattW said:

Yep.  Unfortunately not my first poor experience from them, but it will be my last.

Give them a ring and they will sort it.

They did that to me. Sent me an ex display model in a battered stuck together random cardboard box. The fact dpd delivered it and it had been bumped all over the show didnt help.

On mine, one valve looked lose, there were scratches on it, the vu meter didnt work and the DI was faulty.

To their credit, the guy in Cardiff got in touch and said hed find which store had the best one and replace it, and he did very quickly.

The issue I think is the couriers. Especially now they're so over worked. If they drop or roll it, it's not good.

The one I ended up keeping has a few small Nick's, and the vu light didnt work again, but it played brilliant so I kept it.

Also, Ashdown very kindly offered to have a look if I wasnt happy.

However, PMT were advertising these as clearance, when they're clearly not. They are ex demo or display models.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hope you get sorted with the amp. As to your original question I use a CTM-100 with a Barefaced Two10 and it sounds brilliant - all thumpy and warm. 

  • Thanks 1

Share this post


Link to post
Share on other sites

Did you pay full whack for it? Or was there a deal?

If you paid full whack, I reckon send this back to PMT (hopefully so they don't then just send it on to the next person) and contact Ashdown about purchasing one direct.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for the replies.  It was a really good deal £1039 down from £1999!  However it was advertised as new not as ex demo or a return, but it's clearly had use.  I think it's been dropped as the tubes are all askew, Valve 2 isn't operating and there is no output showing on 2, 3 or 6. Also the bias mode isn't moving the needle on any of the valves.

PMT promptly offered a refund but I also emailed @Ashdown Engineeringand they have offered to collect it and sort it for me, they are only down the road!  Super service as always.  If it comes back working then all good, otherwise PMT can have it back and I'll think again.

  • Like 1

Share this post


Link to post
Share on other sites

Looks like you have that amp on the road to recovery.

Fingers crossed for you as these are stonking amps. I adore mine, even if threads like this constantly make me reassess whether I should be looking for a cab upgrade! (Looking at you @Merton and @stewblack)

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, BruceBass3901 said:

Looks like you have that amp on the road to recovery.

Fingers crossed for you as these are stonking amps. I adore mine, even if threads like this constantly make me reassess whether I should be looking for a cab upgrade! (Looking at you @Merton and @stewblack)

I'm actually selling my Four10 now, lacking in gigs... :(

  • Sad 1

Share this post


Link to post
Share on other sites
12 minutes ago, Merton said:

I'm actually selling my Four10 now, lacking in gigs... :(

Reading that was a rollercoaster of emotions for me... Starting with temptation and excitement (opportunity), touch of jealousy (''he must be upgrading''), then just... SAD.

Fingers crossed we can all get out and gigging again

  • Like 3

Share this post


Link to post
Share on other sites
2 hours ago, MattW said:

Thanks for the replies.  It was a really good deal £1039 down from £1999!  However it was advertised as new not as ex demo or a return, but it's clearly had use.  I think it's been dropped as the tubes are all askew, Valve 2 isn't operating and there is no output showing on 2, 3 or 6. Also the bias mode isn't moving the needle on any of the valves.

PMT promptly offered a refund but I also emailed @Ashdown Engineeringand they have offered to collect it and sort it for me, they are only down the road!  Super service as always.  If it comes back working then all good, otherwise PMT can have it back and I'll think again.

I rang Dave Green after Mark Gooday said to ring him yesterday, as I was biasing my amp. Theyll sort you out.

I had a similar problem with the biasing not moving on certain valves. Dave doesnt think it's an issue. You just balance them to reduce hum. He said use it for 100+ hours then get back in touch.

In all honesty, if ashdown sort everything for you, you have got a great deal there!

Just remember to check the DI too, just in case.

  • Like 1

Share this post


Link to post
Share on other sites

Mine is ready, just waiting for the matching 6x10 to be finished 😍

BE38F87A-5A8A-4D8A-A09B-B5E644617751.png

  • Like 6

Share this post


Link to post
Share on other sites
9 hours ago, BruceBass3901 said:

Looks like you have that amp on the road to recovery.

Fingers crossed for you as these are stonking amps. I adore mine, even if threads like this constantly make me reassess whether I should be looking for a cab upgrade! (Looking at you @Merton and @stewblack)

I'm firmly in the 2X15 camp. Except for the years years I gigged with 8X10.

Hmm.

Guess my feet are firmly in 2 camps!! 

Share this post


Link to post
Share on other sites
9 hours ago, MattW said:

Thanks for the replies.  It was a really good deal £1039 down from £1999!  However it was advertised as new not as ex demo or a return, but it's clearly had use.  I think it's been dropped as the tubes are all askew, Valve 2 isn't operating and there is no output showing on 2, 3 or 6. Also the bias mode isn't moving the needle on any of the valves.

PMT promptly offered a refund but I also emailed @Ashdown Engineeringand they have offered to collect it and sort it for me, they are only down the road!  Super service as always.  If it comes back working then all good, otherwise PMT can have it back and I'll think again.

I've got some gear on the cusp of selling , and was looking to hit the button on one of these from PMT ; but this has put me right off really . Not very good from them - how would I know that they'd not send me another knocked about one?

Share this post


Link to post
Share on other sites
8 hours ago, E sharp said:

I've got some gear on the cusp of selling , and was looking to hit the button on one of these from PMT ; but this has put me right off really . Not very good from them - how would I know that they'd not send me another knocked about one?

The only thing I can suggest is that you can reserve online to collect in your nearest store, so you can see/test it before taking it away and not risk it being couriered.  I should have done that and just waited until after lockdown to get my hands on it.

However thankfully for me Ashdown are very local and I have always had excellent service from them, so looks like I will have it up and running very soon.  It is gutting though when the amp of your dreams arrives in a poor state, and can't say I'd recommend getting one mail order now.

Share this post


Link to post
Share on other sites

Well it's back and sounding amazing!!  So glad I didn't just send it back to PMT, Ashdown were brilliant and had it back to me and all sorted in 3 working days.  It seems it had taken a serious knock, one of the tubed had imploded, everything had shifted and 2 internal fuses has blown.  The packing was completely intact so hard to say of that happened in-store or in transit.  Pretty impressed it made any sound at all when it arrived!

Now it's working at full strength I am super pleased with it, and paired with my Stringray it makes the sound that was in my head but I never quite managed to translate into the real world.  Can't wait to gig it now 😭

Following everyone's advice I have decided to add a second ABM 210 Evo IV cab, it seems thats best compromise of sound/weight/portability/cost - it helps they Thomann have them of special at the moment too!

Thanks everyone for the help!

IMG_20200606_135518999.jpg

  • Like 2

Share this post


Link to post
Share on other sites

Great stuff. Disappointing at first (I had the same issue) but glad it's up and running great now!

  • Like 1

Share this post


Link to post
Share on other sites

Glad you got it sorted.

Enjoy a truly stonking head! Give the switches along the top a good workout to try and see how versatile this amp can be. Each has quite an effect on the way the knobs react as well, so there is plenty to experiment with. The only constant on mine is the Shift switch stays engaged because it just hits so good!

Share this post


Link to post
Share on other sites
13 minutes ago, BruceBass3901 said:

Glad you got it sorted.

Enjoy a truly stonking head! Give the switches along the top a good workout to try and see how versatile this amp can be. Each has quite an effect on the way the knobs react as well, so there is plenty to experiment with. The only constant on mine is the Shift switch stays engaged because it just hits so good!

I started having a good play this afternoon before being told the house was shaking too much 😆

However you are absolutely right, there is a serious range of tones in there, it's certainly not a one trick pony!  I feel like I've only had a taste of what's to come!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...