Jump to content
Left leaderboard
Mrmulluk

Hohner Preamp Dumb Questions!

Recommended Posts

Hey everyone,

 

I’m new to the forum so minor background: 

I haven’t played for YEARS but dusted off my loved Hohner B2A headless to play with. I was hoping to plug it into GarageBand and have a fiddle around, but need an iRig or similar it seems. Stupid technology and real life. 
 

Anyway, 

The red light indicating the preamp is on never comes on, and while it will play passively through an amp the preamp just acts as an off switch. 

Tried so far:

Change battery. Talk sternly to guitar. Cry. 
 

Now I was an utter beginner anyway with the tech side of things, so I’m only vaguely aware at best what the preamp actually does or why I have three volume controls. In my head the preamp will let me plug my bass into GarageBand without using anything but I suspect that is wishful thinking. In short, I guess I just want my red light back. 
 

Please explain as if you were speaking to a small child. A big, fat, bearded small child. 

TLDR: Dumbass has non working B2A Preamp - what do?!

Share this post


Link to post
Share on other sites
Posted (edited)

If it doesn't work in active mode, even after changing the battery, then just switch it to passive and use it in passive mode. To connect it to a software package like GarageBand you will need an audio interface like a Focusrite Scarlett or something similar - https://www.amazon.co.uk/Focusrite-Scarlett-Solo-Audio-Interface/dp/B07QR6Z1JB

 

Edited by ikay

Share this post


Link to post
Share on other sites

Second option is to open the back cover and take few sharp, big and well lit photos. Then share them with us. We may be able to see, if there is a clear issue, that can be repaired. A bass preamp is very simple like a bassist (read: me).

Fifth option is to bring the bass to someone who has some understanding in electronics. S/he can fix the unit for you. OR (option #1) is that this person takes the preamp out and changes it or only takes it away.

Share this post


Link to post
Share on other sites

Another possibility is a battery leakage having damaged the battery (sorry for the repetition) connector. It's quite common.

Take photos, that will help a lot.

Share this post


Link to post
Share on other sites

Hey guys, sorry for the tardy reply, and thanks for the responses so far! 
 

Photos below for smart folk

DF71ED90-0394-4713-98AB-20D3CF186F6C.jpeg

619DBE24-2B7F-46C8-8A1D-1DA9C66A8CC6.jpeg

BB7343AC-5648-4E98-B803-6782EA750FE1.jpeg

Share this post


Link to post
Share on other sites

Crikey, that's a bit of jumble!

Share this post


Link to post
Share on other sites

Nothing looks immediately obvious, but one thing springs to mind.. if a bass has been sat idle for an age, the jack socket and pots can oxidise inside, and as we all know it doesn't take much to interfere with the sound. Try lacing the jack socket with switch cleaner/lubricant such as Servisol Super 10 (other brands are available, and it's great for scratchy pots) and repeatedly insert and remove the jack plug. Something as simple as a bit of a dirty contact might be enough to stop the switching part of the jack socket working, hence no active circuit or LED.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, ikay said:

Crikey, that's a bit of jumble!

It’s like colourful spaghetti, isn’t it!

Share this post


Link to post
Share on other sites

Zooming in, it looks like there's some corrosion on both terminals of the battery connector (and those connectors are pretty flimsy at the best of times). Give it a clean with a stiff brush, and if you've got a multimeter, check that the 9V is actually making it to the preamp board...

Share this post


Link to post
Share on other sites

The first pictures shows your fingers, some vitamin B would be in order.

The third shows the capacitor which is a bit too close to the cover.

Previous comments about corrosion are probably on the right path. Use a plug to put it in several times to the jack. Battery contact, brush it. If you have a DMM (digital multimeter), check cables, too. A battery and a lamp is a cheap and simple tester.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...