Jump to content

Ampeg B100R - She say no....


Recommended Posts

LONG POST WARNING

 

Hi All

 

Bought an Ampeg B100R yesterday for a very, very low price

 

Was listed as spares or repair, so in my mind i was going to rip out the amp and fit a speakon on the back like I did with my BA115HP (again bought as spares or repair a few years ago)

 

Got it home and marvelled at the condition for the cost of approx 4 beers and then decided its a bad move to just ditch the amp section

 

Symptoms...

 

Power on - no power. Dead as a doornail

 

Opened up amp and the 1.5A slow blow was pooped. Checked with a multimeter. No continuity - Ooooo result, but why???

 

New fuse, switched on... hummed a lot and it released a little bit of the magic smoke after around 10 seconds :( bummer. Looked like it came from around the transistors, but cant be sure. Will investigate later. Fuse didn't pop and it still fires up even after losing the smoke.....

 

So..... I've now removed the amp completely and am thinking it might be fun to work through it

 

First things first.... Light bulb tester.... Should I consider putting one together? I am thinking of teeing a bulb holder into an IEM cable. I'm thinking i'd need a 100+ watt bulb to make it work properly. Are these rare items these days?

 

Grille is held in with velcro pads. Persuaded out with a flat blade screwdriver and hope. Will staple a fabric tab on the frame to enable me to pull it out easier next time (next time????)

 

Speaker is fine - tested with another amp and works well. Apart from the dust it looks mint. Code is 86-118-14. 4 ohm. Looks very Eminence..ish

 

My initial prodding with a multimeter seem to indicate the there's a few 0.33 ohm 5w resistors that aren't showing anything like their correct values. 

 

The transistors 2 x TIP142 and 2 x TIP147 seem to show the same readings per "pair". Will remove them later and test them individually

 

I've purchased some new transistors, some resistors (£6 so far) and i've downloaded the circuit diagram for the amp

 

I have a multimeter, a yoghurt pot half full of common sense and a desire not too end my life too early. 

 

If anyone would like to chip in, then please feel free. 

 

If the response is send it to a professional then please save your typing. I can't warrant spending too much on it. My time is my own and learning is good.  If it takes me a few months, but I learn from doing it, then i'll be a happy bunny. If it takes months and it does my head in to the point where I launch it across the garage, then the speakon socket will be installed in the cab and the amp module thrust into the bin in disgust 😁

 

I'll add to this thread as I discover/damage stuff

 

Jon

 

IMG_20220214_082052702_HDR.jpg

IMG_20220213_165037234_HDR.jpg

IMG_20220213_165029064_HDR.jpg

IMG_20220213_165015045_HDR.jpg

Link to comment
Share on other sites

Looks like a fun troubleshooting project! It's a nice tidy PCB, and the output transistors are cheap to replace if needed...

 

Many multimeters won't measure low resistances very accurately, so I wouldn't be too concerned initially about the 0.33R resistors not reading correctly, especially if you're doing it in circuit.

 

Some things to check:

  • If you disconnect the transformer secondary from the board, it shouldn't draw much current. This rules out the transformer and the mains side.
  • Check the power rails are OK - if one of them's present and one's very low, that'd suggest one side of the output has failed. Even better if you can find a way to temporarily break the circuit between the DC rectifier/regulator and the rest of the circuit.
  • Those output transistors are meant to have their tabs insulated from the heatsink. Check that they actually are! (And that there isn't a stray nut trapped underneath, or something.)
  • When you power it up, what's the voltage on the speaker output (before the output filter if it has one)? If it's stuck positive or negative then again that hints as to which side has failed...
  • The electrolytic capacitors are all past their design life at this point - they may still be OK in practice, but you might want to think about replacing them (with 105C versions) once you've got it working.
  • Like 3
Link to comment
Share on other sites

Superb. Thank you.

 

Stuff to look at.

 

I powered it up this evening and found it's a transistor producing the smoke.

 

It lives in a hole in the heatsink near one of the power transistors. I've taken it out.... It's in the second pic. Near the third from the left transistor covered in white goo.

 

I've repaired the headphone socket. The contacts now make when the 1/4 plug is removed.

 

Now to look at the schematic and see what this burnt part should be.

 

Cheers! 

 

 

 

Link to comment
Share on other sites

That is the Vbe bias transistor that sets the quiescent current in the output trannies. If it is dead and gone open circuit then the output trannies are almost certainly blown too as they are likely to have been turned on hard and pulled as much current as they can until the fuses blew.

Link to comment
Share on other sites

  • 4 weeks later...

Well.....

 

Transistor fitted and well pasted

 

Fired up and test driver shoots forward and hums. 

 

Tested the voltage at the speaker terminals and its DC (17v from memory)

 

Hmmm..... this isn't going to be straightforward

 

Where might I begin looking if i'm seeing DC at that point? 

 

Jon

 

Link to comment
Share on other sites

defeat admitted  ☹️

 

Almost threw it out, but have decided to send to my local company who do that sort of thang

 

I was out of my depth knowledge wise and realised that i'd probably end up spending hours throwing components at it before throwing it in the bin anyway

 

I will update when it returns as to exactly what was wrong with it.

 

If the estimate to repair is too high, then I will fit a speakon socket to the cab and use another amp with it instead. 

 

Watch this space

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...