Jump to content
Left leaderboard

paddymac

Members
  • Content Count

    5
  • Joined

  • Last visited

Everything posted by paddymac

  1. UPDATE - FIXED! Well, Justin at Sandberg has been a great help! I really couldn't thank him enough for his advice regards getting to the bottom of the noise mystery with the Electra. I took it to bits, checked all the circuitry connections, drew the diagram on a spreadsheet, took photos, did videos, the works. And now comes the awkward bit whereby I have to hold my hand up and say I am a massive bellend! I thought the bass was running clean through the desk but the cabling was actually going through a ZOOM B3n pedal (purchased brand new not long ago!!) and it was this that was casing the issue!!! After spotting this and actually going direct, the bass sounds amazing. Lesson learned! The B3N has gone back to Gear4music who were happy to collect and we'll see where it goes from there. Anyways. I've uploaded a picture of her and the circuit diagram lest it be of use to another person! Circuit Drawing 260719.xlsx
  2. Thanks both. Bassbunny - Am going to open her up this weekend and have a good look around and take some photos. This will help id the preamp and condition of the parts. Never know, might see something obvious. Will meter the socket too but given the nature of the fault, don't think it's that. Dannyboy - The fault is there is a static noise on all the passive side regardless of pot positions. When you pull the switching pot up to put her into passive mode, the noise is also present right up until you got to full volume then it disappears and the tone is mint. Had a replacement main pot from Synergy but this didn't fix it. Will have a run around with the meter to see if the things that should be earthed are. A diagram would be great though. Have been advised to contact Phil Docker at PMT Birmingham as he apparently has a much wider selection of spares. We shall see! Again, thanks for the input guys 😉 and will upload pics laters.
  3. Hi all, Has anyone had success in getting parts for Sandberg in the UK other than from Synergy Distribution? There seems to be very little support for these cracking basses?! I need to repair an Electra VS4 that has a noise issue (not main pot as changed that already) so am probably looking for a pre-amp set. At the very least i could do with a circuit diagram. I'd like to keep it stock if poss and not change the electronics completely to another brand (recommendations just in case?). Thanks in advance. Paddy - Nottingham. http://www.bassdirect.co.uk/bass_guitar_specialists/Sandberg_ELECTRA_II_Vs_Creme.html?fbclid=IwAR3XWfQlT4FmtNnRYFLDn2wot_LnTah7oX6-Qq8Drfqun4ZK85m9oBp03KY
  4. Cheers for the reply. Had a good poke around and all seems to be connected well. Am going to see about getting the preamp swapped like you say. Just want to make sure i get it right first time 😉
  5. Hi, After a two year break due to breaking my hand, I'm back to start playing again. As I'd previously sold all my gear, I thought I'd get another BTB as my last 770PB Amber was awesome (wish I'd never sold it now!). I picked up an 550MP-NTF in near mint condition with a slight issue on the dual cut pot for a good price. Sounded like a potentiometer easy fix swop. However, after replacing said pot (model 3VR1VM304) the problem still remains. Adjusting this pot results in pops, dead sound and feedback. Therefore, I'm thinking I need to replace the preamp. However, looking online, this is no longer available in the uk. I believe you can get a set from Germany for 155 euros but i'd rather not if i could help it! Has anyone had this problem before I'm wondering? Would anyone have a contact / who is a guru who might be able to supply a circuit diagram/ know a supplier to use / or could be of help? Many thanks in Advance - Mick.
×
×
  • Create New...