Jump to content
Left leaderboard
JackLondon

DIY Effects

Recommended Posts

Does anyone know where I could buy an ECG778 dual op-amp from?

It's for a Dr. Q clone. The TL072 that I have in there just now isn't cutting it.

Cheers

Share this post


Link to post
Share on other sites

Continuing on the topic of SMT, Big Clive has been doing a few videos on reflow recently that some in this thread may find interesting.

 

Share this post


Link to post
Share on other sites

I've seen people do DIY paste stencils with vinyl cutters etc. - but I think very quickly you hit a point of diminsihing returns with SMT in DIY - but it might be something we have to contend with as the big manufacturers are gradually pivtoing away from through-hole packages for a lot of ICs/Transistors.

As an aside - does anyone happen to have an EPROM burner and the burning (see what I did there) desire to be super helpful?

Share this post


Link to post
Share on other sites

EPROMs?

These day people just use NAND flash which is reprogrammable at standard supply voltages.

What do you need an EPROM for?

Share this post


Link to post
Share on other sites
4 minutes ago, Stub Mandrel said:

EPROMs?

These day people just use NAND flash which is reprogrammable at standard supply voltages.

What do you need an EPROM for?

Evil tinkering - finally getting round to doing the XP-All mod to my old Digitech XP-100 -  https://www.circuitbenders.co.uk/newsarchive/XPALL.html

Annoyingly I bought all the stuff years ago when I worked at a PCB assembler and had access to an EPROM burner - but didn't have the foresight to burn the chip while I had access so I'm hoping to find some kind soul who has one knocking about in the loft. Backup plan is to use my spare raspberry pi, which can apparently do it from the GPIO.

Share this post


Link to post
Share on other sites
2 minutes ago, bobbass4k said:

Evil tinkering - finally getting round to doing the XP-All mod to my old Digitech XP-100 -  https://www.circuitbenders.co.uk/newsarchive/XPALL.html

Annoyingly I bought all the stuff years ago when I worked at a PCB assembler and had access to an EPROM burner - but didn't have the foresight to burn the chip while I had access so I'm hoping to find some kind soul who has one knocking about in the loft. Backup plan is to use my spare raspberry pi, which can apparently do it from the GPIO.

Should be loads of legacy EEPROMers on the web, most used to run of a PC parallel port IIRC.

Share this post


Link to post
Share on other sites
On 09/05/2020 at 14:36, paul_5 said:

the good old LM741, which I love in overdrive/distortion pedals. The 741 gets a lot of stick on electronics forums from Hi-fi buffs, as it's old and noisy in comparison to newer ICs, but that's precisely why it sounds so darn good in O/D units!

Many many years ago my first ever pedal was a Ross Distortion. I was just getting into electronics as a teenager and read all this stuff about TL071s being better than the LM741 so swapped out the 741 in my pedal. It didn't take long before it was swapped back in again and I started learning more about things like slew rate etc.

Share this post


Link to post
Share on other sites
Posted (edited)

I am venturing in to here again. Don't laugh at me.

This is an odd one. During my forays into bass Ukes I had some Fdek pres built. But they are in various stages of completion. One is a bare circuit board that the builder cannot remember where he was in the process. I suspect it is complete but needs pots and power. But I could be wrong. If you have the skills to decipher what is going on with it would you consider finishing it for me for ££££?

The second is I think complete but there is an earth hum thing going on. It has been mounted in a Boss chassis, can be powered by 9v psu or battery. It has one vol pot, and two three way switches. One switch for HPF and one for passive tone roll off. The footswitch is NOT on off. It does not function as a switch. It takes and puts out signal and it all works just with an added serving of hum.  Again, would someone mend this for ££££££?

The only guy round here who would do it is not functioning.

TIA.

15913912283641799445843646661132.jpg

15913912642394695390740464609661.jpg

15913912882044714997761405054495.jpg

Edited by owen

Share this post


Link to post
Share on other sites
On 05/06/2020 at 22:08, owen said:

I am venturing in to here again. Don't laugh at me.

This is an odd one. During my forays into bass Ukes I had some Fdek pres built. But they are in various stages of completion. One is a bare circuit board that the builder cannot remember where he was in the process. I suspect it is complete but needs pots and power. But I could be wrong. If you have the skills to decipher what is going on with it would you consider finishing it for me for ££££?

The second is I think complete but there is an earth hum thing going on. It has been mounted in a Boss chassis, can be powered by 9v psu or battery. It has one vol pot, and two three way switches. One switch for HPF and one for passive tone roll off. The footswitch is NOT on off. It does not function as a switch. It takes and puts out signal and it all works just with an added serving of hum.  Again, would someone mend this for ££££££?

The only guy round here who would do it is not functioning.

TIA.

15913912283641799445843646661132.jpg

15913912642394695390740464609661.jpg

15913912882044714997761405054495.jpg

Sorting out my own perf board is a nightmare, someone else's is a no go for me, Sorry.

Share this post


Link to post
Share on other sites

I had forgotten about this!

I have no reason to believe that the perf board is not functioning as it should. It should be an Fdeck. If anyone wants it then shoot me an address and it is yours for nothing.

Share this post


Link to post
Share on other sites
Posted (edited)
43 minutes ago, owen said:

I had forgotten about this!

I have no reason to believe that the perf board is not functioning as it should. It should be an Fdeck. If anyone wants it then shoot me an address and it is yours for nothing.

OK I fell for it. Send it to me and I will look at it. I will PM you.  Do you have the circuit diagram/schematic? If I get it working I will send it back to you.

Edited by Chienmortbb

Share this post


Link to post
Share on other sites
On 10/05/2020 at 14:06, pete.young said:

With the switch in bypass, it's showing about 0.5 Ohm on the 200 Ohm range. With the switch engaged, it's gone up to about 1.2 MOhm on the 2M range, which is the highest this meter has.

Apologies for the slow update. I've now sorted this and it's working properly. The problem turned out to be that R1 had failed open circuit and I hadn't been paying proper attention to the resistance measurement. Replaced it with a new resistor and all was well.

Learning point for me - if I make any more pedal kits I'll be sure to check the resistance value of all the resistors before I solder them onto the board. Schoolboy error!

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, pete.young said:

Apologies for the slow update. I've now sorted this and it's working properly. The problem turned out to be that R1 had failed open circuit and I hadn't been paying proper attention to the resistance measurement. Replaced it with a new resistor and all was well.

Learning point for me - if I make any more pedal kits I'll be sure to check the resistance value of all the resistors before I solder them onto the board. Schoolboy error!

To be fair, a fresh resistor going open on it's own is pretty rare, you've been very unlucky there. I would say routinely checking all your parts pre-soldering is waaay overkill. A common cause of opens is mechanical stress on the leads, make sure you're not bending them too sharply, some people do it with pliers which can be fine but its easy to overdo it. 

Edited by bobbass4k
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
On 27/05/2020 at 15:53, bobbass4k said:

Evil tinkering - finally getting round to doing the XP-All mod to my old Digitech XP-100 -  https://www.circuitbenders.co.uk/newsarchive/XPALL.html

Annoyingly I bought all the stuff years ago when I worked at a PCB assembler and had access to an EPROM burner - but didn't have the foresight to burn the chip while I had access so I'm hoping to find some kind soul who has one knocking about in the loft. Backup plan is to use my spare raspberry pi, which can apparently do it from the GPIO.

Bit of a zombie discussion alert...

We definitely have a Stag and a Lloyd in the lab at work, not that that's much help :lol: 
however... I think I might have an old Dataman programmer lurking in my drawer in the office. If I can think up an excuse to go in one day this week, I'll check. If it's there and it fires up, you can have it, if it'll be of any use..?

Edited by Rich

Share this post


Link to post
Share on other sites
17 hours ago, Rich said:

Bit of a zombie discussion alert...

We definitely have a Stag and a Lloyd in the lab at work, not that that's much help :lol: 
however... I think I might have an old Dataman programmer lurking in my drawer in the office. If I can think up an excuse to go in one day this week, I'll check. If it's there and it fires up, you can have it, if it'll be of any use..?

Stag prgrammer, that takes me back.

Share this post


Link to post
Share on other sites
10 minutes ago, Chienmortbb said:

Stag prgrammer, that takes me back.

Same here. I had an eprom programmer in the loft for years, finaly gave it away about 10 years ago after not using it for 10 years. Wish I could do that wiht the rest of this stuff!

Share this post


Link to post
Share on other sites
On 22/06/2020 at 14:41, Rich said:

Bit of a zombie discussion alert...

We definitely have a Stag and a Lloyd in the lab at work, not that that's much help :lol: 
however... I think I might have an old Dataman programmer lurking in my drawer in the office. If I can think up an excuse to go in one day this week, I'll check. If it's there and it fires up, you can have it, if it'll be of any use..?

Ooops sorry haven't been on in a while. It'd definitely be a massive help if you had one knocking about, I'd only need it for a few days (assuming I could figure it out in that time...), I'd massively appreicate it.

On a different note, the fruits of lockdown -

IMG_20200702_222231.thumb.jpg.c8bec3e80fde223e4bd623b25fdf4616.jpg

I've finally got into label printed graphics (waaaaay better than transparent waterslide decals) and I apologise for nothing.

Top - EQD Ghost echo clone, lovetone doppelganer clone (phaser), madbean dreamtime (an amazing FV-1 delay in a 1590a)

Bottom - Frostwave funk-a-duck clone (absolutely mad envelope filter), DBA space ring with improvements (deadendfx wurmloch, ring mod)

Rate LEDs on the phaser are tempoerarily a bit rough because the 10mm LED bezels I thought I had were actually 8mm, so they're bezel-less for now

 

  • Like 3

Share this post


Link to post
Share on other sites

@bobbass4k you have a PM :)

Share this post


Link to post
Share on other sites
On 03/07/2020 at 00:10, bobbass4k said:

Ooops sorry haven't been on in a while. It'd definitely be a massive help if you had one knocking about, I'd only need it for a few days (assuming I could figure it out in that time...), I'd massively appreicate it.

On a different note, the fruits of lockdown -

IMG_20200702_222231.thumb.jpg.c8bec3e80fde223e4bd623b25fdf4616.jpg

I've finally got into label printed graphics (waaaaay better than transparent waterslide decals) and I apologise for nothing.

Top - EQD Ghost echo clone, lovetone doppelganer clone (phaser), madbean dreamtime (an amazing FV-1 delay in a 1590a)

Bottom - Frostwave funk-a-duck clone (absolutely mad envelope filter), DBA space ring with improvements (deadendfx wurmloch, ring mod)

Rate LEDs on the phaser are tempoerarily a bit rough because the 10mm LED bezels I thought I had were actually 8mm, so they're bezel-less for now

 

How did you put the labels on? I have tried that in the past and  found it hard to get them correctly positioned and you only get one chance.

Share this post


Link to post
Share on other sites
1 hour ago, Chienmortbb said:

How did you put the labels on? I have tried that in the past and  found it hard to get them correctly positioned and you only get one chance.

One way is to damp the surface with water with a little detergent in it. It does mean you have to wait for it to dry out.

Share this post


Link to post
Share on other sites
Just now, Stub Mandrel said:

One way is to damp the surface with water with a little detergent in it. It does mean you have to wait for it to dry out.

Are the lables special?

 

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, Chienmortbb said:

How did you put the labels on? I have tried that in the past and  found it hard to get them correctly positioned and you only get one chance.

Mostly just patience, I marked the labels and the boxes with the mid points then peeled the back off just a tiny bit of the corner, i found that way i could align the bulk of the label with the midpoints then press the corner down, then you can pull the back off and it'll stick itself, smoothing it as you go. Not all mine are completely straight but they're close enough.

One annoyance I did find is that the clearcoat I use (plastikote gloss) took a full day and a half to dry on the labels, as opposed to overnight for the painted bits. 

2 hours ago, Chienmortbb said:

Are the lables special?

 

I just got some inkjet gloss label paper from amazon, with a decent clearcoating it should hold up just fine.  I think you can get some thicker, fancier stuff from specialist places but it's expensive. 

Oh and a final tip, you'll notice the stargate one (bottom right) looks quite dark and blue saturated, because the clearcoat has soaked through on to the dark blue of the enclosure. I couldn't be bothered redoing it but I learned my lesson for the phaser - i put that label on to another plain white label first to give an extra backing and the results are much better.

Edited by bobbass4k

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...