Jump to content
Left leaderboard
Sign in to follow this  
philbillbass

My vt2 dual custom bass pedal is broken :(

Recommended Posts

i decided to have a go with this pedal again as i hadn't used it for a while. And it doesn't work, not a peep out of it. It powers up with the led's. But gives me no sound unless i have it in bypass mode (obviously!). What do i do with it now?
Phil

Share this post


Link to post
Share on other sites

[quote name='philbillbass' post='673088' date='Dec 3 2009, 12:53 PM']i decided to have a go with this pedal again as i hadn't used it for a while. And it doesn't work, not a peep out of it. It powers up with the led's. But gives me no sound unless i have it in bypass mode (obviously!). What do i do with it now?
Phil[/quote]

Send it back for repair

Share this post


Link to post
Share on other sites

[quote name='philbillbass' post='674379' date='Dec 4 2009, 05:43 PM']So can i just send it back to you? What is the charge?[/quote]

depends what's wrong with it, if you purchased it from me and if its under a year old.

Share this post


Link to post
Share on other sites

[quote name='philbillbass' post='675504' date='Dec 6 2009, 10:54 AM']Nah I bought it from kev on this forum. It was made in June 07.
Phil[/quote]


Happy to look at it for you and repair at cost plus postage.

Dave

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...