Jump to content
Sign in to follow this  
JBassist

Amp keeps Cutting Out

Recommended Posts

i posted a thread a couple of days ago saying that my amp was crackling alot and cutting
[url="http://basschat.co.uk/index.php?showtopic=54969&st=0&p=544876&#entry544876"]http://basschat.co.uk/index.php?showtopic=...mp;#entry544876[/url]
i followd some advice and sprayed some switch cleaner down the inputs

i played it today for basically the 1st time since i sprayed and now it just cuts out
it dosnt crackle it just cuts out
it does it every 5mins and comes back once i turn on/off

any help?


xxx
xx
x

Edited by JBassist

Share this post


Link to post
Share on other sites

The only advice I can offer is to find a reputable repairer to take a look. Costly I know, but probably worth it in the long run.

Share this post


Link to post
Share on other sites

You have a short, it gets hot as its running overloaded due to the short, and the thermal safety cut-out is kicking in. Once its cooled again the thermal safety cut out resets and you can play agin.
Needs professional servicing to locate the short.
If its a valve amp this could be particularly dangerous. Not to be attempted by the uninitiated in the pwer of electriccery. Seriously.

Share this post


Link to post
Share on other sites

Mine too, not every 5 minutes though.

Reckon it's joint problems on the inards when it warms up. The heat expands all the joints probaly causing a break in the circuitry.

As someone earlier said, take it to a tech who can follow circuit diagrams. My amp is a Trace Elliot for reference.

Share this post


Link to post
Share on other sites

[quote name='farmer61' post='549121' date='Jul 23 2009, 04:26 PM']Mine too, not every 5 minutes though.

Reckon it's joint problems on the inards when it warms up. The heat expands all the joints probaly causing a break in the circuitry.

As someone earlier said, take it to a tech who can follow circuit diagrams. My amp is a Trace Elliot for reference.[/quote]

Hi I repaired a trace recently which had this problem. It was the cooling fan. The fan should run continuously. If the fan is not running its either the fan is faulty, or the cicuit which drives the fan and controls its speed as the amp gets hotter. Your probably finding it cuts out when its being pushed at proper gig level rather than playing quietly at home.
Hope this of some use
Cheers Just

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...