Jump to content

Bass Draining Battery


stewblack
 Share

Recommended Posts

19 hours ago, Jo.gwillim said:

I'm pretty sure that's right. I'm not saying they're shorting but those Jack socket solder joints don't look as though they've been made by someone who solders very often... doesn't inspire confidence. Good luck! 

 

7 hours ago, Hellzero said:

Hard to tell from the photos, but as @Jo.gwillim said, those solders don't look very trustable... And might short the negatives together, which means "Always On".

I shall have a closer look - thanks both. I don't wish to cast nasturtiums on the skills of the solderer at the Ibanez factory, in fact I can guarantee that they are better at it than I am! 

However I can stop things touching where they shouldn't. 

Link to comment
Share on other sites

It could be a wiring fault. Most often the battery circuit is completed by inserting the jack plug. The exception to this is usually on an acoustic bass with a built in tuner. Often the tuner is switched on with a small push button independently of the jack and it's easy to leave it on - I've done it more than once on my Taylor bass! I suppose the logic is that you still want to be able to tune the bass to play acoustically? makes sense but is not bass player proof 🙂

 

Link to comment
Share on other sites

  • 2 months later...
Posted (edited)

Hi folks,, today I have a break from the worst of my symptoms so I'm tackling this problem. 

I appreciate nobody can diagnose with certainty a fault over the internet but something might leap out at you. 

Here is the socket IMG_20210102_103748.thumb.jpg.03414adfdc91f77fe0bd3a15c6e0ce09.jpgIMG_20210102_103650.thumb.jpg.6d4a7a63c3b138dc43b0767c336e13d3.jpg

and I see no short. Checked all three joints for continuity between them and found none. 

Edited by stewblack
Link to comment
Share on other sites

On 26/09/2020 at 21:07, stewblack said:

IMG_20200926_122025.jpg

IMG_20200926_122032.jpg

There's your problem, someone's stolen all your wiring.  Your bass can't possibly work properly without a tangled rats nest of wiring far too big for the cavity.  And all that dead space in there means that by basic physics lots of electrons packed together in the battery must migrate to a space where's there's less electrons. Without the usual mess of wire to prevent them escaping, they just will.

Edited by lownote12
  • Haha 3
Link to comment
Share on other sites

To me, the solders on the output barrel jack look suspicious (dry solders) and the nut needs to be re-screwed to the max.

The shorting by a screw near the piezo output card could have been a possibility, but it's the grounding, so no.

My advice is this : go to a friend or someone who knows electronics, he will fix the problem(s) faster than anyone remotely who can only be guessing.

Link to comment
Share on other sites

Posted (edited)
23 minutes ago, Hellzero said:

My advice is this : go to a friend or someone who knows electronics, he will fix the problem(s) faster than anyone remotely who can only be guessing

Ultimately I shall take it to someone. I'm just keen to learn all I can, and if there is anything I can do myself I'd like to try it. 

Oh and don't worry about theoose nut on the barrel, I loosened that on purpose. 

Edited by stewblack
Link to comment
Share on other sites

I read this on TB:

If wired properly, the battery ground is only attached to the ring terminal of the jack. So another way to check for drain would be to use the resistance (ohms) or continuity setting of the meter, and see if that ring terminal is connected to ground anywhere without a cable plugged into the jack.

I did as suggested and got readings in all sorts of places. 

Link to comment
Share on other sites

1 hour ago, stewblack said:

I read this on TB:

If wired properly, the battery ground is only attached to the ring terminal of the jack. So another way to check for drain would be to use the resistance (ohms) or continuity setting of the meter, and see if that ring terminal is connected to ground anywhere without a cable plugged into the jack.

I did as suggested and got readings in all sorts of places. 

This is with the battery out certainly (with the battery in things can be different). With 'normal' active wiring, the socket acts as a swtich, so the ring goes to the battery negative and nowhere else (as you say). When the plug goes in, the socket shorts out the ring and the shield and negative terminal of the battery is shorted to ground, which powers the preamp. 

As the wiring here is very simple, it is worth checking. it should be purely one wire that connects battery -  to the output socket ring and not connect to anywhere else. If it is wired like that, there is no battery in and there is no plug in the socket and you can read any connectivity with any instrument you have (and you are not touching the probes), your socket is broken.

  • Thanks 1
Link to comment
Share on other sites

Hi Stew, The soldering on the jack socket does not look like a factory job to me, so it is possible that the socket has been re-soldered or  replaced at some point. They're not the most reliable of components and I've lost count of the number of sockets I've replaced on  instruments, including Warwick basses (even made in Germany instruments) that use this type of jack. It is possible that it's been incorrectly wired. The ring connection should be connected directly to the battery negative and nothing else. The tip is signal and sleeve ground. As the bass works when a fresh battery is fitted, it is likely that the tip is correctly wired but the ring and sleeve may be reversed. If you have a TRS jack lead and a multimeter, plug the lead in and check for continuity between the ring and battery negative terminal with the battery removed. 

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

@basstone thank you so much Tony. This is why I come to you for my repairs.

Diagnosed the problem from a photograph and gave clear instructions as to how to fix it. 

All done and sounds great. Probably my imagination but it seems to sound louder 🤷🏻‍♂️

 

  • Like 2
Link to comment
Share on other sites

2 hours ago, Hellzero said:

Good news, but each and every advice was to check that barrel jack and its solders from the start. 😉

Indeed. The key difference was Tony told me exactly what needed doing to establish which wires went where. 

No matter, I'm grateful when anyone offers advice if I have a problem. 

I just feel the particular advice which enables me to solve a problem deserves particular and specific thanks. I mean no disrespect to anyone else. 

  • Like 3
Link to comment
Share on other sites

15 hours ago, Hellzero said:

Good news, but each and every advice was to check that barrel jack and its solders from the start. 😉

It is an indication that I need to communicate better, as I thought I said the same thing.

Maybe I should be more consise.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...