Jump to content
Nicko

Latency problems

Recommended Posts

I got a free version of Ableton Live Lite 10 with my midi keyboard which I loaded onto an ageing laptop.  Although the DAW works OK for using clips and when I draw in midi signals, there is so much latency on live recorded audio that its not actually possible to record anything.  It's not the monitoring that's the issue, it seems to be the time taken from hitting a note on the keyboard (or guitar) to register in the recording.  I'm direct monitoring audio in through the interface so I know I'm playing (vaguely) in time but playback is way off.

Same problem happens with playing notes on the midi keyboard (which is input via the usb rather than the interface), and I can hear the delay in response when monitoring the live signal in.

I've set the sampling rates to minimise the latency but still no joy.  I suspect it may be that the computer isn't up to the job, even though it meets the minimum system requirements.  

Is it likely to be a lack of RAM, the chipset is too slow or something else I've missed?

 

Share this post


Link to post
Share on other sites

Windows or Mac?

It is affected by many factors. 

Faster processor helps as does sticking in as much memory as it’ll take. 

Do you have an external audio interface? That will help. If not, download and install ASIO4ALL and disable all other sound drivers. Disable stuff like mics, onboard speakers, DVD drive and internet cards (wireless and wired).

Other things that slow stuff down are background processes. Check what’s loading at startup and disable anything you don’t need. 

Download and run Latencymon and you’ll see what’s hogging processing power. Go through the list and remove or disable anything that isn’t needed. 

Share this post


Link to post
Share on other sites

There is a tutorial within ableton help to set the hardware latency correctly. Have you tried that?

Share this post


Link to post
Share on other sites
1 hour ago, Quatschmacher said:

Windows or Mac?

It is affected by many factors. 

Faster processor helps as does sticking in as much memory as it’ll take. 

Do you have an external audio interface? That will help. If not, download and install ASIO4ALL and disable all other sound drivers. Disable stuff like mics, onboard speakers, DVD drive and internet cards (wireless and wired).

Other things that slow stuff down are background processes. Check what’s loading at startup and disable anything you don’t need. 

Download and run Latencymon and you’ll see what’s hogging processing power. Go through the list and remove or disable anything that isn’t needed. 

Thanks.

I'm running a focusrite 2i2 with the latest drivers through a windows laptop.  I can see the background processes on task manager, but not having much of a clue about computers I don't actually know what the processes that are running do so I'm a little cautious of stopping them.  I'll take a look and see if I can work out how to disable those you've suggested and take some time to google the processes that are running.

The midi keyboard is running direct through the USB port.

I can't do anything about the processor, but could throw an extra ram chip in as there's a free port

 

Share this post


Link to post
Share on other sites
22 minutes ago, GisserD said:

There is a tutorial within ableton help to set the hardware latency correctly. Have you tried that?

I'll take a look.  Thanks

Share this post


Link to post
Share on other sites

Seriously, download latencymon. There’s a guide which tells you why the processes are and which ones are safe to disable. 

You can also do something about the processor - many have a power saving mode which speeds it up and slows it down as required. This needs turning off to so that the processor runs at full speed the whole time. There are other options within the power management menu that control stuff like window transitions, animations, etc, all of which take their toll. I think all this might have been covered in the latencymon document too. 

Share this post


Link to post
Share on other sites
18 hours ago, Quatschmacher said:

many have a power saving mode which speeds it up and slows it down as required. This needs turning off to so that the processor runs at full speed the whole time.

Did that yesterday and it made a noticeable difference.

  • Like 1

Share this post


Link to post
Share on other sites

Ableton should tell you the likely latency in your setup if you check in the Live/Preferences/Audio menu. (I'm running Live 9 on Mac so may be different for you). What numbers are you seeing in there and what is the buffer size set to?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...