Jump to content
Sign in to follow this  
bubinga5

Saffire not working through Mac Pro on Sierra...?

Recommended Posts

Ive just updated my MacPro to Sierra. I have a Focusrite Saffire Pro 24 running into it, but its not recognising the interface.? I can play and hear the bass, but audio/signal from YouTube isn't running through the interface.

Im thinking I need to update the Saffire software.?

Any ideas.?

Edited by bubinga5

Share this post


Link to post
Share on other sites

I guess so yes, make sure that model is supported by Sierra. It should as Focusrite are usually bang on with updates. My interface, albeit a different model, has been working well.

The only other thing I can think of is to reinstall and then make sure that Focusrite Control is configured correctly.

Share this post


Link to post
Share on other sites

I take it you've checked Audio / Midi setup on the mac, to check software outputs are correctly routed to the interface and not the built in speakers?

Failing that driver reinstall should hopefully do the trick (I don't use focusrite so can't give more specific advice unfortunately).

Share this post


Link to post
Share on other sites

Get in touch with Sibob. He works at focusrite and helped me out when I had the same issue a couple years ago with a software update. Unfortunately I can't remember what it was he told me to do!

Share this post


Link to post
Share on other sites

I can confirm that the interface should work with sierra as I have it and I have sierra and I recorded some stuff just last night!

Check audio preferences and make sure that the Safire is routed properly. Alongside that try opening the Safire mix control and seeing if that helps. The college I'm the Technician at has a Safire 56 and it only seems to work with the mix control open too!

Share this post


Link to post
Share on other sites

Ok thanks guys. Yeah the Mac is only recognising built in speakers. Mix Control won't open either. So I presume it needs a software update.

Edited by bubinga5

Share this post


Link to post
Share on other sites

[quote name='bubinga5' timestamp='1506440797' post='3378769']
Ok thanks guys. Yeah the Mac is only recognising built in speakers. Mix Control won't open either. So I presume it needs a software update.
[/quote]

Indeed it sounds like it. See if you can fully uninstall the existing Mix Control before installing the new update.

Share this post


Link to post
Share on other sites

You can load drivers which are not OS compliant by unclicking the padlock thing in Security and Privacy in the System Preferences doobrie and allowing Apps downloaded from anywhere.

That is how my Ozonic keyboard/interface lives to fight another day.

Share this post


Link to post
Share on other sites

My work here is done!!! ;)




Sorry, only just seen this :)
Glad you're sorted

Si // Focusrite Media Relations

Share this post


Link to post
Share on other sites

[quote name='Sibob' timestamp='1506638819' post='3380172']
My work here is done!!! ;)




Sorry, only just seen this :)
Glad you're sorted

Si // Focusrite Media Relations
[/quote] :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×
×
  • Create New...